Collision issues with environment/NPCs

  • I'm having some issues with custom collision parts not being detected by game entities and map collisions. I've tested this with both a lightbar and a brushguard, the only time the collision works is if it is shot, or walked on/into by the player. Interaction with the parts on other vehicles and the game world have no collision. Such as, the brushguard won't have any collision when touching NPC vehicles/game world entities. The lightbar has the same issue, such as flipping the car over, the lightbar will not "support" the car. It acts as if a collision isn't present, cutting through the map. I have IDs 116 for the brushguard and lightbar collision.

  • I've now checked again, the only collision used for crash detection is the chassis collision. Edit: It seems like any collision works if set up properly. However, it is not possible to simply attach further floating parts, as explained here: http://forum.zmodeler3.com/viewtopic.php?f=31&t=7349
    It's necessary either model those parts into the collision or use groups and compound the group.

  • I've now checked again, the only collision used for crash detection is the chassis collision. However, it is not possible to simply attach further floating parts, as explained here: http://forum.zmodeler3.com/viewtopic.php?f=31&t=7349
    It's necessary either model those parts into the collision or use groups and compound the group.

    Yeah, you directed me to that earlier. Yet I'm a bit skeptical. My LAPD Caprices have added collisions for the lightbar glass which actually works with environmental collisions. Those are separate from any linked collisions, their own parts.

  • Is it a slot specific or model issue? Add those parts to your LAPD Caprice and replace the collisions with something you know works. If the collisions are the problem, maybe you need new ones or fix the axes.


    I wouldn't take Oleg's word at face value. He very often has bad intuitions and then claims his game crashes when he's asked to test.

  • Is it a slot specific or model issue? Add those parts to your LAPD Caprice and replace the collisions with something you know works. If the collisions are the problem, maybe you need new ones or fix the axes.


    I wouldn't take Oleg's word at face value. He very often has bad intuitions and then claims his game crashes when he's asked to test.

    Model issue. I've tried the collision parts, but no avail.