Resetting my files

  • Good afternoon, I'm a veteran GTA player but very new to the modding scene. Around the time of the Diamond Casino update, I was modding GTA relatively lightly, with car packs, a track that spawned outside the map, disabling speed barriers and such, but then rockstar updated GTA, and Steam consequently updated my GTA. I don't know how to revert to old versions of the game so I could continue playing, so I simply waited for the new version of Scripthook to come out. Once it did and I installed it as I did the old version, my GTA crashed upon loading, after the selection of loading into Story Mode. I uninstalled it, deleted it's files, hit verify integrity, tried again, uninstalled everything after it failed, and have uninstalled it about four times fully. However, even now, when I load it up I still see Natural Vision on the bottom left of my screen, indicating my mod files are still there, and more than likely outdated and the root of my issue. I would highly appreciate it if somebody were to help me figure out how to completely reset my GTA files so I can once again resume modding, and just even play. Steam support has done absolutely nothing.

    Thank you in advance,

    -Blazed Chillist

  • Hello,

    if there are still mods being loaded after you've uninstalled and reinstalled the game, you've most likely not deleted your mods folder and the .asi loader (dinput8.dll), plus potentially other script mods. Steam can only remove the original game files when uninstalling. To make absolutely sure that there are no more mods installed, uninstall the game and delete any files that are still in your GTA 5 folder.

    Your game crashing after the update is most likely caused by having an outdated gameconfig.xml. A modified gameconfig is required for many mods that add content, such as addon cars, peds or weapons. The gameconfig requires changes for every major update, you'll need to make sure to find one that is compatible with the current version.

  • It's working now! Thank you so much! I uninstalled GTA via Steam, and like you said i then looked in the files and, sure enough, there were plenty of files left behind that Steam didn't take. I deleted everything and reinstalled GTA and now it works like a dream! I'll definitely be looking around this website for help doing things correctly this time! Once again thank you so much, I had tried everything that I could think of.