Looking for Help on linking Polys Together in Zmodeler

  • I'm working on converting a 3d object that is in a .obj file format to work for GTA 5. The problem is that whoever made the model I'm assuming took the whole thing and made a copy of it and "flipped" the polys so they would be on both sides so I have been going through and manually deleting them on the other side of each piece before I continue.

    But My problem is when I try to use the separated tool in Zmodeler that I usually use to select multiple polygons it is only selecting one at a time and really dragging the process. Is there anything I can do to possibly link the polygons together?

    Here is a video of what I am doing and what I am getting:
    https://www.youtube.com/watch?v=rxU9Qw7 ... e=youtu.be


    Oleg had mention that I didn't import it properly in the beginning by optimizing the vertices and that was the problem but I had made a video of me doing it that way and I still get the same problem:


    Video of What I did:
    https://www.youtube.com/watch?v=J7xfpvh ... e=youtu.be



    Thanks,
    Thero

  • First: If the polygons are seperated in the original model, it will not work no matter how you import it.



    The two videos you have linked are not available. I don't know what the model looks like, but I'll try to explain it in a way that should work with most objects.


    There is a way to weld each side automatically. Without seeing the model, I can't guarantee it will work, but it should be possible. First, I recommend to activate wireframe and outline in your viewpoint settings if they aren't already, this way you can see where polygons are seperated and where they are connected. To weld automatically, activate the option "Multiple Targets" and select all vertices you want to weld. Before doing that, I recommend to detach all parts of the object that are actually supposed to be seperated, since otherwise the UV map and the normals could get messed up.


    Left click to open the tool's options and change the settings the following way. As soon as you update one of the values, ZModeler previews the change. That way with the outline option set in the viewpoint, you should be able to see if it works.

    • Vertices Distance: Since the vertices should be in the same spot, a very low disntance should be set. Depending on the detail level of the model, something like 0.001 or 0.0005 should probably work.
    • UV tolerance: If the object is continously mapped, what I imagine it most likely is, you can keep the default value. If it is not, you'll need to increase the number as much as necessary. Please note that in that case, the original UV map will be changed and it is likely necessary to create a new one.
    • Normals Angle: This is the important option to weld each side seperately instead of welding everything together. If one side is flipped, the normals should consequently also be flipped. You'll therefore need an angle below 180°. If the normals are not correctly flipped, you'll need to calculate them first.

    If it all worked, you should be able to select each side using the "Seperated" selection tool.

  • If both sides are also welded together, it's best to use the Break tool on all verts before, and then use the multiple weld. just use the lowest settings, 0.0001 (just scroll down once on the first value) and UV lowest too (scroll down once again) and start with a low angle until it looks how you want it. Oh I forgot, before rewelding, make sure to calculate normals after breaking them so they "reset".