err_str_failure3

  • Hello modding forum community.


    I am writing this post today to seek help on a recurring problem im having with zm3.

    to explain im working on a ambulance model scratch made from blender3d and i have ran through

    and followed the process of putting it together by replacing a development model i found on lspdfr.com.


    https://www.lcpdfr.com/downloa…ev-model%C2%A0by-pimdslr/


    So as advised by the zm3 forum i replaced every part it had with my model's parts, and then i exported it for testing

    and then i got the str failure 3 game error. Doing some digging i found out its related to missing parts or collisions.

    I'm completely baffled into why this is happening, I have done all LOD's and borrowed collisions and parts and replaced there geometries

    from other gta models.


    There was one instance where i was able to get it to spawn but not without glitches. In the pictures that i will provide for you you can see

    the model is slanted to the side and the wheels are missing,


    https://drive.google.com/file/…EF26t2a3/view?usp=sharing

    https://drive.google.com/file/…5HxKTUse/view?usp=sharing

    https://drive.google.com/file/…u0qQ6yX5/view?usp=sharing


    trying to retrace my steps was-

    1. Not assigning liveries to paint 3.

    2.Not having wheel mesh ng etc or whatever.

    3.Ticking skelatal mode when exporting.

    4.Exporting with the proper LOD's per yft.


    There are more steps but im trying to remember them all.

    So my request is if someone reads this can they take a look at the z3d file for me and verify that everything is correct hierarchy wise?

    And advise me what to do further, I have other projects in the works but cannot put them through until i get this solved.

    If someone can help me with that i would love your help.


    Thank you in advance.

  • Yeah had this issue, make sure your textures inside your YTD are DXT5 and Mitmaps 1. This can be done in the YTD if you look in the top right, when selecting a texture, there will be a properites tab.

  • adamenforcers I've found that error can also be caused by a poly using the default material (not given a material in ZMOD; basically blank) or the Base Value not being high enough. These occurrences and the ones above are only time I've seen it personally. Also I believe the DXT5 thing only applies to 4K and above textures, so really only liveries.

  • adamenforcers I've found that error can also be caused by a poly using the default material (not given a material in ZMOD; basically blank) or the Base Value not being high enough. These occurrences and the ones above are only time I've seen it personally. Also I believe the DXT5 thing only applies to 4K and above textures, so really only liveries.

    interesting, well there is no texture in the default material so would i just replace that with a texture i already have or a gta one? when i exported the last few times i noticed on the zm3 message board about "required textures" i think a bump map or something like that on certain textures, i don't remember the rest it said regarding that. i find it strange it managed to spawn that time and i did not do anything extensive in the material browser than the following steps. Speaking of the base value should i manually add it in? this dev model in question had no base value whatsoever when i got it and i heard through this guy saying it should be deleted

    .

  • interesting, well there is no texture in the default material so would i just replace that with a texture i already have or a gta one? when i exported the last few times i noticed on the zm3 message board about "required textures" i think a bump map or something like that on certain textures, i don't remember the rest it said regarding that. i find it strange it managed to spawn that time and i did not do anything extensive in the material browser than the following steps. Speaking of the base value should i manually add it in? this dev model in question had no base value whatsoever when i got it and i heard through this guy saying it should be deleted

    As far as a default texture, make there is is not object or poly that is using the Default Texture. They should all be using a material besides that or else your gonna get an error. Also I'm not too sure about deleting base value, all models I've made and people I interact with include it. So yeas add it in manually.

  • As far as a default texture, make there is is not object or poly that is using the Default Texture. They should all be using a material besides that or else your gonna get an error. Also I'm not too sure about deleting base value, all models I've made and people I interact with include it. So yeas add it in manually.

    ok can you delete the default texture or add a texture to it?

  • adamenforcers Sorry for late response, I work two jobs and go to school... You shouldn't need to do anything to default material. It just kinda exists. Basically when something isnt assigned a material it uses the default material to apply a texture to it.

    No problem, what are these bump maps and where do i find them? according to zm3 they are required textures, and one more thing texture wise, should the format be .dds or .png?

  • adamenforcers So as far as textures go,


    Detail - The colors and image you see. Usually different for every material


    Bump - Usually the 'purple' looking texture. This gives the material that 3D look. A vehicle_generic_bumpmap will give it an overall flat look. Bumpmaps are used to give detail without making additional poly's


    Spec - The glossiness of the material; Blacker it is the less an environment will be mirrored. Vehicle paint will use a white specmap, something like nylon or wood would use a black specmap


    Env - Environment; not really sure what it does, never really tested, just use same env on every material


    I use both dds and png, I think dds is slightly better but png allows for transparency

  • ok everything else i can handle, but one last question what would be in regards to the missing wheels and rims what is the process for that?